Easee cloud account issues
Incident Report for Easee
Resolved
This incident has been resolved.
Posted Nov 19, 2021 - 16:50 CET
Investigating
We are investigating issues with account activations.
Posted Nov 19, 2021 - 15:11 CET
This incident affected: Easee Cloud & API and Easee Portal.