IoT backend downtime
Incident Report for Easee
Resolved
This incident has been resolved.
Posted Nov 16, 2020 - 08:26 CET
Update
The Easee cloud has now been stable and operational for a full day.
We are still monitoring all functions and working on getting the historic data up.

You should be able to use your app as normal now but historical data might still be missing 😄

Have a wonderful day ❤️
Posted Nov 15, 2020 - 10:44 CET
Monitoring
We are able to maintain a stable connection but we still have some services which deliberately have not been activated.

You should at this point be able to see and control your charger through our app or your operators app but there might be some mismatches in statuses or slower response times than normal.

Historical data is being rebuilt so you might not yet see historical consumptions or any of the offline sessions being uploaded yet.

At this stage we do not recommend generating reports from the portal.

We finally seem to have things under control. We have our amazing team still working on ensuring stability and we will continue working throughout the weekend to get back on track with everything. 🎉

It is at times like this that we get to know what lives in all of us. It is so easy to point fingers, get angry and frustrated and demand to be compensated somehow.
From the bottom of our hearts we appreciate the support so many of you have shown in this difficult period ❤️🙌🏼
All the amazing people in Easee are also just people and they have been working day and night to get things back on track and it means so much for them as well to know that we have some amazing customers cheering for them, we do not take this for granted and we promise you that we will continue to work hard to maintain that trust.

We will let you know as soon as we know when to expect everything to be back on track. Thank you again so much, have a wonderful weekend 🙏❤️⚡️
Posted Nov 14, 2020 - 00:29 CET
Update
We see a positive trend in our Cloud after the controlled ramp up of services we have just performed. We see more and more chargers going online.

Please be patient with checking the charger status in the app and we will update you shortly when we can ensure stability over a longer period. The app or other operator systems may vary on the online/offline statuses.
Posted Nov 13, 2020 - 18:21 CET
Update
We are gaining more and more control. We have been able to establish an internal connection with most of the chargers. We are now working on gradually enabling all services and preparing for going back to normal operation. The chargers will still be unavailable in the app and in all systems until we have all systems operational.

We are not in in the clear yet as we have not confirmed system operation end to end but we have high hopes that we will be able to restore the system today based on what we see and the current point of time.

Thank you all again for your patience and support ❤️🙌🏼⚡️
Posted Nov 13, 2020 - 15:03 CET
Update
We have managed to set up the queue system again and we will now start gradually connecting chargers and re-activating our systems and services. Activation of all services will be done in a gradual and controlled manner throughout the day.

You might see that you charger is online from time to time. We will come with another update when we believe that things are stable enough to expect full control.
Posted Nov 13, 2020 - 10:01 CET
Update
We have been able to gradually connect more and more chargers so some of you might from time to time get sporadic connections. However we are still experiencing sporadic crashes so we are not in the clear yet.

We need to take a small step back and we are now bringing the whole system back down to force offline mode on all chargers again. This should give back offline logic so that the chargers with the right offline settings can charge when offline.

We will do some further improvements and tweaks and give it another go.

We have our whole team working on solving this problem. We have also involved several external support services through our hosting partners.

Today we made some good progress, although we hoped to be back this afternoon we believe we are getting closer to solving this.

Again thank you for you patience 🙌🏼⚡️
Posted Nov 12, 2020 - 21:25 CET
Update
We have been working throughout the day on rebuilding our backend services to be able to establish a connection with all the chargers over time. We have been able to verify that everything runs as it should on a low pace with a handful of devices. We will be connecting towards chargers in small batches to see that everything is working as it should as the volume grows. We will start taking in chargers which have the strictest offline behaviour meaning the chargers that can only be controlled by an app or by approval of an EaseeKey from a central system.

Because we are bringing chargers back online in batches we are still some hours from the final solution, we will keep you updated throughout the afternoon and evening. We are very confident in the work done today and the plan ahead of us in securing stability and going back to normal operation.

We thank you all for your patience and support you have shown us over this downtime period ❤️🙌⚡️
Posted Nov 12, 2020 - 15:12 CET
Update
We are continuing to work on a fix for this issue.
Posted Nov 11, 2020 - 23:43 CET
Identified
The issue has been identified and a fix is in the works. A failure in the cloud system resulted in all chargers re-connecting almost simultaneously and overloading the cloud system with messages and offline data transactions. We have a system for avoiding overload in such situations but it seems we have hit a limit in the amount of simultaneous connections.

We are now working on rebuilding the queue logic in order to be able to successfully connect all chargers again.

Offline mode:
The system has now been set in deliberate offline mode meaning that all chargers should operate locally as defined by the offline logic. Offline logic varies from operator to operator. For Easee customers the default behaviour is that it should be possible to charge without having to authenticate as long as the charger is offline.

Some other operators demand that a known Easee key is used while others accept any Keytag.

Chargers running a schedule will start charging when the defined schedule is set to start.
Chargers controlled by a partners smart charging like Tibber should start charging as long as the charger is in offline mode.

Cable is locked:
If you want to unlock the cable you can do so by accessing the local WiFi interface and unlocking the cable. Read more about the local WiFi interface here: https://www.notion.so/easee/Easee-charger-local-interface-b9ff6002acef4c3794531f68a6664d79


What next:
We are working on a new queue logic to take into account the massive load when chargers reconnect to the cloud. At current point in time we believer that we will have something ready tomorrow.

We truly understand your frustration. We promise you that we have initiated several new improvements to avoid this from happening again with the effect it has had. We are doing everything we can to make the system bullet proof even if the cloud is not working as it should.
We will improve on our offline functionality which will allow local operation in situations like this 😔 We are at the same time doing everything we can to fix the situation and to stabilise and future proof the solution. We we have everyone in the organisation working on resolving this.

Again we are truly sorry, we are just humans and we are learning new things everyday. We have experienced an enormous growth and the speed of the growth has gradually caused more challenges than we have been able to foresee. We are working on scaling both our organisation and our systems, identifying short term and long term fixes to ensure stability. We thank you all for your support and patience. We will make things right again please trust us on that ❤️⚡️☺️
Posted Nov 11, 2020 - 23:43 CET
Investigating
We are still working on getting to the core issue of the problem. We have all our resources on the incident.
Posted Nov 11, 2020 - 15:21 CET
Identified
The Easee cloud is currently experiencing some problems. This affects our API, Apps, & OCPP. For most customers, the charger should work in offline mode and still work locally. We are very sorry about this and we are working hard to fix this issue.
Posted Nov 11, 2020 - 08:18 CET
This incident affected: Easee Cloud & API, Easee Portal, and OCPP.